読者です 読者をやめる 読者になる 読者になる

Paradigm Shift Design

ISHITOYA Kentaro's blog.

Flashプレーヤーのセキュリティアップデート

一昨日研究室に泊ることになった原因は、結局のところ、
2008年4月のFlash Player 9のセキュリティアップデートについて | デベロッパーセンター
このセキュリティアップデートによるものでした。
9.0.115.0では、crossdomain.xmlがなくても、警告が出るだけでSocketにつなげることができていたのですが、9.0.124.0ではエラーになって実行が止まってしまっていました。


原因追究に時間がかかった理由は…C#Flex、送信側アプリケーション、プロキシアプリケーション、受信アプリケーションと3つのアプリがあり、PCも4台利用しているため、問題の切り分けに時間がかかったこと、それから各PCにデバッグ環境がなかったことが原因かな。


まぁ、原因がわかったのはいいのだけれど、結局
Adobe - カスタマーサポートからのお知らせ
からデバッグアーカイブを取得して9.0.115.0をインストールして解決してしまっていて、crossdomain.xmlについて知識を深めようとしていない…
ちゃんと勉強しなきゃいけないみたいなんだよなぁ。


ちなみにバージョンを落とそうとするとエラーが起きることがあります。
Flashプレーヤーのバージョンを落とすときのエラー - Paradigm Shift Design